Page loading issues

Incident Report for ClearGov

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 15:44 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 15:43 EDT

Investigating

We are currently investigating intermittent issues that may cause slow performance or errors within the ClearGov platform. Our engineering team is actively working to identify the root cause and implement a fix to restore full functionality.
Posted Aug 26, 2025 - 13:11 EDT
This incident affected: Capital Budgeting, Personnel Budgeting, Operational Budgeting, Digital Budget Book, Transparency, ClearGov Administration, and Public Website.