ClearGov experiencing loading and connectivity issues
Incident Report for ClearGov
Resolved
The incident has been resolved.
Posted Jun 30, 2023 - 12:47 EDT
Update
We are continuing to investigate this issue.
Posted Jun 30, 2023 - 12:25 EDT
Investigating
We are currently investigating a loading and connectivity issue with ClearGov applications.
Posted Jun 30, 2023 - 11:54 EDT
This incident affected: Capital Budgeting, Personnel Budgeting, Operational Budgeting, Digital Budget Book, and Transparency.