ClearGov application availability issue
Incident Report for ClearGov
Resolved
This issue has been resolved.
Posted Nov 15, 2023 - 10:05 EST
Investigating
ClearGov is investigating an issue affecting the application. Please do not make data updates until this is resolved. We will provide the next update by 10:30am EST.
Posted Nov 15, 2023 - 09:25 EST
This incident affected: Capital Budgeting, Personnel Budgeting, Operational Budgeting, Digital Budget Book, Transparency, ClearForms, and ClearGov Administration.